Production outage
Incident Report for Beyond/PeachWorks
Resolved
S3 is back to operational
Posted Feb 28, 2017 - 16:51 EST
Update
From Amazon:
S3 object retrieval, listing and deletion are fully recovered now. We are still working to recover normal operations for adding new objects to S3.
Posted Feb 28, 2017 - 16:19 EST
Update
From Amazon:
We are seeing recovery for S3 object retrievals, listing and deletions. We continue to work on recovery for adding new objects to S3 and expect to start seeing improved error rates within the hour.
Posted Feb 28, 2017 - 15:55 EST
Update
Update from Amazon:

We continue to experience high error rates with S3 in US-EAST-1, which is impacting various AWS services. We are working hard at repairing S3, believe we understand root cause, and are working on implementing what we believe will remediate the issue.
Posted Feb 28, 2017 - 14:51 EST
Investigating
We're experiencing a Production outage due to Amazon S3 increased error rates.
Posted Feb 28, 2017 - 14:32 EST
This incident affected: Beyond One (Apps, Developer Portal), External Services (AWS S3 (US-Standard)), and PeachWorks.com.